いろいろやってみるにっき

てきとーに生きている奴の日記

https化に伴い、表示できなくなっているリンクについて修復中。
2018年から遡って修正し、2015年分まで修正完了。


ChromeOS FlexでZoomを動かす

エディタをインストールできてサーバが立ち上げられてお絵描きできれば、一応仕事に使える。あとは何かなと思ったらZoomだなと。ドキュメントや表計算は一応インストールを試す予定だけどGoogle DocsやOffice Onlineでできる。

 

shigeo-t.hatenablog.com

shigeo-t.hatenablog.com

shigeo-t.hatenablog.com

shigeo-t.hatenablog.com

 

Zoomのインストール手順はこちら。

support.zoom.us

 

まず最初の sudo apt install gdebi を実行しておく。長いので省略。

 

次はダウンロード。ダウンロードページはこちら。

zoom.us

 

Linuxのタイプを聞いてくる。今回は以前にDebianだと調べているのでDebianを選択する。

バージョン11なので9.0+を選択。

ダウンロードファイルをLinuxファイルに移動する。

sudo apt install ./zoom_amd64.deb を実行する。

jsflightning2@penguin:~$ sudo apt install ./zoom_amd64.deb
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Note, selecting 'zoom' instead of './zoom_amd64.deb'
The following packages were automatically installed and are no longer required:
  gyp javascript-common libc-ares2 libjs-highlight.js libjs-inherits
  libjs-is-typedarray libjs-psl libjs-typedarray-to-buffer libnode-dev
  libnode72 libuv1 libuv1-dev node-chownr node-color-name node-err-code
  node-extsprintf node-fast-deep-equal node-indent-string node-ini
  node-is-typedarray node-json-parse-better-errors node-json-schema
  node-json-schema-traverse node-qs node-resolve-from node-through
  node-typedarray-to-buffer node-universalify node-uuid nodejs-doc
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  bubblewrap gir1.2-ibus-1.0 gnome-desktop3-data gstreamer1.0-gl
  gstreamer1.0-libav gstreamer1.0-plugins-bad gstreamer1.0-plugins-base
  gstreamer1.0-plugins-good gstreamer1.0-x ibus ibus-data ibus-gtk ibus-gtk3
  im-config libaa1 libaacs0 libass9 libavc1394-0 libavfilter7 libavformat58
  libbdplus0 libbluray2 libbs2b0 libcaca0 libcdparanoia0 libchromaprint1
  libdc1394-25 libdca0 libdv4 libdvdnav4 libdvdread8 libegl1-mesa libfaad2
  libflite1 libfluidsynth2 libgl1-mesa-glx libgme0 libgnome-desktop-3-19
  libgraphene-1.0-0 libgssdp-1.2-0 libgstreamer-gl1.0-0
  libgstreamer-plugins-bad1.0-0 libgstreamer-plugins-base1.0-0 libgupnp-1.2-0
  libgupnp-igd-1.0-4 libharfbuzz-icu0 libhyphen0 libibus-1.0-5 libiec61883-0
  libinstpatch-1.0-2 libjavascriptcoregtk-4.0-18 libkate1 liblilv-0-0 libltc11
  libmanette-0.2-0 libmjpegutils-2.1-0 libmms0 libmodplug1 libmpcdec6
  libmpeg2encpp-2.1-0 libmpg123-0 libmplex2-2.1-0 libmysofa1 libnice10 libnorm1
  libofa0 libopenal-data libopenal1 libopengl0 libopenmpt0 libopenni2-0
  libpgm-5.3-0 libpipewire-0.3-0 libpipewire-0.3-modules libpocketsphinx3
  libpostproc55 librabbitmq4 libraw1394-11 librubberband2 libsbc1 libsdl2-2.0-0
  libserd-0-0 libshout3 libslang2 libsndio7.0 libsodium23 libsord-0-0
  libsoundtouch1 libspa-0.2-modules libspandsp2 libsphinxbase3 libsratom-0-0
  libsrt1.4-gnutls libsrtp2-1 libssh-gcrypt-4 libswscale5 libtag1v5
  libtag1v5-vanilla libudfread0 libv4l-0 libv4lconvert0 libvidstab1.1
  libvisual-0.4-0 libvo-aacenc0 libvo-amrwbenc0 libvorbisfile3
  libwebkit2gtk-4.0-37 libwildmidi2 libwpe-1.0-1 libwpebackend-fdo-1.0-1
  libxcb-xtest0 libxkbregistry0 libzbar0 libzmq5 pipewire pipewire-bin
  pocketsphinx-en-us python3-ibus-1.0 timgm6mb-soundfont xdg-dbus-proxy
  xdg-desktop-portal xdg-desktop-portal-gtk zenity zenity-common
Suggested packages:
  frei0r-plugins gvfs ibus-clutter ibus-doc libbluray-bdj libdv-bin oss-compat
  libdvdcss2 libvisual-0.4-plugins libportaudio2 libraw1394-doc serdi sndiod
  sordi gstreamer1.0-alsa libwildmidi-config fluid-soundfont-gm accountsservice
  evince
The following NEW packages will be installed:
  bubblewrap gir1.2-ibus-1.0 gnome-desktop3-data gstreamer1.0-gl
  gstreamer1.0-libav gstreamer1.0-plugins-bad gstreamer1.0-plugins-base
  gstreamer1.0-plugins-good gstreamer1.0-x ibus ibus-data ibus-gtk ibus-gtk3
  im-config libaa1 libaacs0 libass9 libavc1394-0 libavfilter7 libavformat58
  libbdplus0 libbluray2 libbs2b0 libcaca0 libcdparanoia0 libchromaprint1
  libdc1394-25 libdca0 libdv4 libdvdnav4 libdvdread8 libegl1-mesa libfaad2
  libflite1 libfluidsynth2 libgl1-mesa-glx libgme0 libgnome-desktop-3-19
  libgraphene-1.0-0 libgssdp-1.2-0 libgstreamer-gl1.0-0
  libgstreamer-plugins-bad1.0-0 libgstreamer-plugins-base1.0-0 libgupnp-1.2-0
  libgupnp-igd-1.0-4 libharfbuzz-icu0 libhyphen0 libibus-1.0-5 libiec61883-0
  libinstpatch-1.0-2 libjavascriptcoregtk-4.0-18 libkate1 liblilv-0-0 libltc11
  libmanette-0.2-0 libmjpegutils-2.1-0 libmms0 libmodplug1 libmpcdec6
  libmpeg2encpp-2.1-0 libmpg123-0 libmplex2-2.1-0 libmysofa1 libnice10 libnorm1
  libofa0 libopenal-data libopenal1 libopengl0 libopenmpt0 libopenni2-0
  libpgm-5.3-0 libpipewire-0.3-0 libpipewire-0.3-modules libpocketsphinx3
  libpostproc55 librabbitmq4 libraw1394-11 librubberband2 libsbc1 libsdl2-2.0-0
  libserd-0-0 libshout3 libslang2 libsndio7.0 libsodium23 libsord-0-0
  libsoundtouch1 libspa-0.2-modules libspandsp2 libsphinxbase3 libsratom-0-0
  libsrt1.4-gnutls libsrtp2-1 libssh-gcrypt-4 libswscale5 libtag1v5
  libtag1v5-vanilla libudfread0 libv4l-0 libv4lconvert0 libvidstab1.1
  libvisual-0.4-0 libvo-aacenc0 libvo-amrwbenc0 libvorbisfile3
  libwebkit2gtk-4.0-37 libwildmidi2 libwpe-1.0-1 libwpebackend-fdo-1.0-1
  libxcb-xtest0 libxkbregistry0 libzbar0 libzmq5 pipewire pipewire-bin
  pocketsphinx-en-us python3-ibus-1.0 timgm6mb-soundfont xdg-dbus-proxy
  xdg-desktop-portal xdg-desktop-portal-gtk zenity zenity-common zoom
0 upgraded, 125 newly installed, 0 to remove and 0 not upgraded.
Need to get 109 MB/241 MB of archives.
After this operation, 804 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 https://deb.debian.org/debian bullseye/main amd64 bubblewrap amd64 0.4.1-3 [43.0 kB]
Get:2 https://deb.debian.org/debian bullseye/main amd64 libibus-1.0-5 amd64 1.5.23-2 [406 kB]
Get:3 https://deb.debian.org/debian bullseye/main amd64 gir1.2-ibus-1.0 amd64 1.5.23-2 [317 kB]  Created symlink /etc/systemd/user/default.target.wants/pipewire.service → /usr/lib/systemd/user/pipewire.service.
(中略)
Created symlink /etc/systemd/user/sockets.target.wants/pipewire.socket → /usr/lib/systemd/user/pipewire.socket.
Setting up gstreamer1.0-libav:amd64 (1.18.4-3) ...
Setting up zenity (3.32.0-6) ...
Processing triggers for desktop-file-utils (0.26-1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for libglib2.0-0:amd64 (2.66.8-1) ...
Processing triggers for libgtk-3-0:amd64 (3.24.24-4+deb11u2) ...
Processing triggers for libgtk2.0-0:amd64 (2.24.33-2) ...
Processing triggers for libc-bin (2.31-13+deb11u4) ...
Processing triggers for man-db (2.9.4-2) ...
Processing triggers for shared-mime-info (2.0-1) ...
Setting up ibus (1.5.23-2) ...
Setting up zoom (5.11.10.4400) ...
run post install script, action is configure...

 

インストールできたようなので確認。アイコンがあるのでクリックする。

起動できた。

 

起動できたのでサインインする。認証のブラウザは前回インストールしたChromiumに行った。Chromiumは自動起動。なぜかスマホっぽく開く。

このPCにはカメラが無いけどちょい試してみる。

 

ちゃんと繋がる。

 

日本語化は起動して最初の画面で自分のアイコンを開き、HelpからLanguage Settingsで日本語を選び一度停止。

起動すると日本語になる。

 

ということで問題なく使える。